CVE-2026-67405
EUVD-2026-8565623.09.2026, 21:17
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler (deps/rabbitmq_web_mqtt/src/rabbit_web_mqtt_handler.erl:104) nor the Web-STOMP handler (deps/rabbitmq_web_stomp/src/rabbit_web_stomp_handler.erl:102) validates the Origin header on the WebSocket upgrade. Under ssl_cert_login=true, the browser presents the client certificate automatically, so an attacker's JavaScript running in the victim's browser can authenticate as the victim. Preconditions include The non-default configuration use_http_auth=true (Web-STOMP) or ssl_cert_login=true (both plugins) must be enabled. The issue is harmless under the default in-band CONNECT credential configuration.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.Enginsight
Affected Products (NVD)
| Vendor | Product | Version |
|---|---|---|
| broadcom | rabbitmq_server | 3.13.0 ≤ 𝑥 < 3.13.15 |
| broadcom | rabbitmq_server | 4.0.0 ≤ 𝑥 < 4.0.20 |
| broadcom | rabbitmq_server | 4.1.0 ≤ 𝑥 < 4.1.11 |
| broadcom | rabbitmq_server | 4.2.0 ≤ 𝑥 < 4.2.6 |
𝑥
= Vulnerable software versions
Debian Releases
Ubuntu Releases
Common Weakness Enumeration