CVE-2026-94054

EUVD-2026-83612
Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, has an out-of-bounds write.
ProviderTypeBase ScoreAtk. VectorAtk. ComplexityPriv. RequiredVector
NISTPrimary
7 HIGH
NETWORK
HIGH
NONE
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L
Base Score
CVSS 3.x
EPSS Score
Percentile: 19.06%
Affected Products (NVD)
VendorProductVersion
eximexim
𝑥
< 4.100.1
𝑥
= Vulnerable software versions
Debian logo
Debian Releases
Debian Product
Codename
exim4
bookworm
vulnerable
bookworm (security)
vulnerable
forky
4.100.1-4
fixed
sid
4.100.1-4
fixed
trixie
vulnerable
trixie (security)
4.98.2-1+deb13u5
fixed
Ubuntu logo
Ubuntu Releases
Ubuntu Product
Codename
exim4
bionic
needs-triage
focal
needs-triage
jammy
Fixed 4.95-4ubuntu2.12
released
noble
Fixed 4.97-4ubuntu4.8
released
resolute
Fixed 4.99.1-1ubuntu1.5
released
trusty
needs-triage
xenial
needs-triage